
Using 2001 Census Data In ArcView 3.3 and Census Data in 
Beyond 20/20 Tables 

 
 

These procedures outline: 
1. Downloading and opening the Cartographic Boundary Files (CBF) 
2. Downloading and joining the attribute (data) files with the CBF 

 
A. Importing an Arc Export File 
 
Digital Cartographic Files are available for download from the University of Toronto 
Data Library Services:  Census 2001 Spatial Data Files, located at the University of 
Toronto URL below: 
 
http://0-www.chass.utoronto.ca.innopac.lib.ryerson.ca/datalib/cc01/geospat01.htm
 
This site provides the option to download either Digital Boundary Files (DBF) or 
Digital Cartographic Files (DCF) in Arc/Info or MapInfo formats. In this example, the 
Arc/Info digital cartographic file at the census tract level is used. Often Arc/Info 
Cartographic files(.e00 extension) are found in Arc Export File formats (.exe extension). 
In order to view a desired Arc Export file in ArcMap  9.0, follow the steps below. 
 
*Note – To access the files from a computer located off the Ryerson campus, you must 
be a Ryerson University student (full-time or continuing education), staff or faculty 
member and have a matrix (e-mail) account. 
  
Example: 
 
1. Scroll down to Hamilton (537) and  Download the *.exe file (gct_537b02a_e.exe) for 
Arc/Info to your disk.  (the file size of gct_535b02a_e should be 297KB) 
 
2.  Once this file has been downloaded, locate the file and unzip it in order to extract the 
file. 
 
3. In order to convert the Arc/Info export file for use in ArcView, you will use ArcView 
Import 71.  Double-Click on the Import71 icon or select Start > Programs > ESRI > 
ArcView GIS 3.3 > Import71 
 
4 (a).  The Import71 Utility window will open.   
 
4 (b).  (Figure 1)  In the Export Filename select Browse then locate the *.e00 file in 
the directory you downloaded it to, select it, then select Open.  
(Eg. C:\esri\tordcf\gct_537b02a_e.e00). 
 
4 (c).  In the Output Data Source select Browse and the destination location where 
you want the file to be extracted to.  After the last back slash (\), type in the output file 
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http://0-www.chass.utoronto.ca.innopac.lib.ryerson.ca/datalib/cc01/geospat01.htm


name with no extension (Eg. C:\esri\tordcf\ gct_537b02a_e.  Select OK.  Click OK 
when the Import Complete appears.    
 

 
(Figure 1) 

 
 

 
B.  Opening the ArcInfo Coverage in ArcView 3.3 
 
1.  Double-Click on the ArcView GIS 3.3 icon or select Start > Programs > ESRI > 
ArcView GIS 3.3 > ArcView GIS 3.3. 
 
2.  In the Welcome to ArcView GIS window click with a new View, then click OK. 
 
3.  In the Add data window, it asks you: “Would you like to add data to the View 
now?”, click Yes. 
 
4.  In the Add Theme window, browse to the boundary file (Example C:\esri\tordcf\ 
gct_537b02a_e).  Click OK. 
 
5.  Maximize the window titled View1, and maximize the window titled ArcView GIS 3.3. 
 
6.  Click the little grey box (a check mark will appear) left of the word gct_537b02a_e. 

 
 
You now have a layer showing the Hamilton CMA with census tract boundaries.  In 
ArcView this layer is called a theme. 
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C.  Converting From a Coverage to a Shape-file 
1.  Make sure that gct_537b02a_e is active (by clicking on the file name).  From the 
main menu click Theme > Convert to Shapefile and give it a name (Eg. Hamct.shp).  
Select Yes, when asked to Add shapefile as theme to the view. 
 
2.  Make gct_537b02a_e active, and from the main menu select Edit > Delete Themes 
> Yes To All.   
 
3.  Now display Hamct.shp and make it active by clicking on the file name and putting a 
check in the little grey box beside the Hamct.shp name.    
 
 
D. Getting Attribute Census 2001 Data 
 
1.  You may download the data from Census of Canada, 2001: Profile Series located 
at the site listed below: 
 
http://0-www.chass.utoronto.ca.innopac.lib.ryerson.ca/datalib/cc01/profil01.htm 
 
There are 9 subject profiles: 

1. Profile of language characteristics 
2. Profile of aboriginal communities 
3. Age and sex 
4. Marital status, families & household living arrangements, and housing 
5. Language, mobility, and migration 
6. Citizenship, immigration, birthplace, generation status, ethnic origin, visible 

minorities and aboriginal peoples 
7. Labour force activity, class of worker, occupation, industry, place of work, mode 

of transportation, language of work and unpaid work 
8. School attendance, education, field of study, highest level of schooling and 

earnings 
9. Profile of income of individuals, families and households, social and economic 

characteristics of individuals, families and households, housing costs, and 
religion 

 
At the Census tract level there is also an “All Canada file” and a “CMA Toronto Subset” 
As you can see on the website, these files are available at many geographic levels that 
include: 
 
A. Census Subdivision (CSD)   
B. Dissemination Area (DA) 
C. Forward Sortation Area (FSA)   
D. Census Metropolitan Area (CMA) / Census Agglomeration (CA)  
E. Census Tract (CT) 
F. Federal Electoral District (FED) 
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*Note:  In order to continue this exercise, you must have a version of Beyond 20/20 that 
is version 6.2 or later.  If you do not have this program, you can go to the website below 
and download it: 
 
http://0-www.chass.utoronto.ca.innopac.lib.ryerson.ca/datalib/caq/b2020.htm 
 
-Then select the link beyond-6-2.exe. when prompted to save, select a desired location 
and then save.  The file will be compressed (zipped), thus you have to uncompress it in 
order to use it. 
1(a).  For this exercise we will use: School attendance, education, field of study, 
highest level of schooling and earnings at the C. Census Tract (CT) Level, 
therefore, select 95f0491xcb01005.  
 
1(b). Then select Open. 
 
A Beyond 20/20 Professional Browser version 6.2, should open.   
 
The first task is to switch the position of the Columns and the Rows.  The Census 
Metropolitan Areas with their census tract numbers should be at the side, while the 
variables should be along the top. 
 

 
(Figure 2) 
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2.  Select the Geography heading, now hold the button down and drag it over to the 
heading that says Profile of Cens.  Then release the button, now the Census 
Metropolitan Areas with their census tract numbers are in the left column (your 
screen should look like Figure 2). 
 
2(a).  Make sure the Geography heading is highlighted in yellow.  From the Main Menu 
Bar select  Dimension > Search.   

Field = English Desc 
Text to Find = 537 
Type of Selection = Reduce 
OK 

 
2(b).  We only want Census Tracts which are within the Hamilton Census 
Metropolitan Area, so we will hide the extras.   

Highlight Hamilton (537) 00000 
From the Main Menu select Item > Hide 
Now scroll down to the bottom of the data and highlight the last 3 census 
tracts (0537.01, 0537.02, 0537.03) 
From the Main Menu select Item > Hide 
 

 
 
The ones we have hidden don=t start with 537 with the number in brackets,  
ie 0537.01 (602053701) 00000.  So now if you scroll the table from top to bottom there 
should only be census tracts that in the brackets start with 537. 
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2(c).  From the Main Menu Bar select File > Save As > Ham01.dbf (Make sure you 
change List Files of Type to dBase File (*.dbf) 
 
2(d).  Select OK and again OK when it says ADuplicate code(s) detected, unique 
codes will be generated@ (You can now close the Beyond 20/20 program as it is not 
needed anymore).  
 
3.  Open Microsoft Excel 
 
3(a).  File > Open > (browse to the location of the saved Ham01.dbf) > Open (Make 
sure you change Files of Type to dBase Files (*.dbf) 
3(b).  Select Column A  (Make sure the entire column is highlighted) 

From the Main Menu Bar select Data > Text to Columns 
The Convert Text to Columns Wizard - Step 1 of 3 will open. 
For Original Data Type = Fixed Width 
Click Next 
 
The Convert Text to Columns Wizard Step 2 of 3 will open 
Simply Click Next 
 
The Convert Text to Columns Wizard Step 3 of 3 will open, 
Select the first column (the one with the two decimal places) then 
under the Column Data Format heading Select Text 
Click Finish 
Select OK for the ADo you want to replace the contents of the 
destination  cells?@ 

 
3(c).  Highlight Columns B & C.  Then Edit > Delete > Columns B & C 

(You will also notice that the column title for column A has been altered, simply 
click on the title and change it back to Geography) 

3(e). Highlight the entire worksheet by selecting the grey cell above the Row 1, and 
left of Column A. 

From the Main Menu Bar select Data > Sort  
Sort By = GEOGRAPHY 
Select Ascending 
Click OK 
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4.  Save the file.  You may choose to give the file a new name or retain the old one.  
Make sure that you choose DB4 in the Save as type column.  A warning will pop up 
indicating that your dbf file may contain features that are not compatible with DB4 
(dbase IV) and will ask you if you would like to keep the workbook in the current format.  
Click Yes.  Then close Microsoft Excel.  If the save prompt pops up, simply follow the 
procedures above.  Close Microsoft Excel. 
 
 
 
 
 
 
E.  Opening the Data File in ArcView 3.3 
 

1.  From the main menu, select Window.  Click Untitled. 
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(Figure 2)   

 
2.  (Figure 2)  In the Untitled window, click Tables from the left menu, then click 

Add from the top menu.  In the Add Table window browse to Ham01.dbf, select 
it, then click OK. 

 
F. Joining the Files 
Explanation of what occurs when two tables are joined: 
 
You can join a database table to an ArcView table (e.g., a shapefile theme's attribute 
table), if they share common fields of values. All of the rows selected by the database 
table's query can be joined to the ArcView table.  
 
The contents of the ArcView table changes to include the joined attributes from the 
database table while the database table remains open and unchanged.  
The joined attributes are not permanently part of the ArcView table. ArcView gets the 
joined attributes from the database using a join query taken from the database table's 
query at the time of the join. If the values in the database change you can see those 
changes by refreshing the joined table. When you open a saved project, ArcView will 
recreate the join and retrieve the appropriate values into the local table. 
 
The join query is not linked to the database table's query. After joining a database table 
and a local table, if you change the database table's query in a way that affects which 
rows are joined, the rows joined to the local table won't change when you refresh its 
values. To update which records are joined, you need to remove the join from the local 
table then join the tables again following the steps above. 
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1.  Click on the field labelled Geography (this is the census tract name column which is 
needed in order to join the database file to the attribute table).  Now sort datafile records 

in ascending order   (3rd last button in the middle row).  Minimize (DO NOT CLOSE) 
the Ham01.dbf table however REMEMBER to leave the Geography field highlighted. 
 
2.  Select Window from the main menu and click View1.  Click Hamct.shp to make it 

active (do not double click).  Click the Open Theme Table button .       
 

3.  Click on the field labelled Ctname, to which the datafile will be joined.  Sort boundary                      

file records in ascending order . 
 
4.  Make sure that Attributes of Hamct.shp is active (meaning, this is the current 
window that you are looking at).  From the Main Menu select Table > Join.  The 
Ham01.dbf file should disappear.  Scroll along the boundary file to see if the *.dbf file 
data fields are present. 
 
If the procedure was carried out correctly the new table should look like (Figure 3).  You 
have now completed the process of getting census data.  In addition, the Hamilton 
census data is now joined to the Hamilton CMA shapefile. 
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