
Using 2001 Census Data In ArcMap 9.0 and Census Data in 
Beyond 20/20 Tables 

 
 

These procedures outline: 
1. Downloading and opening the Cartographic Boundary Files (CBF) 
2. Downloading and joining the attribute (data) files with the CBF 

 
A. Importing an Arc Export File 
 
Digital Cartographic Files are available for download from the University of Toronto 
Data Library Services:  Census 2001 Spatial Data Files, located at the University of 
Toronto URL below: 
 
http://0-www.chass.utoronto.ca.innopac.lib.ryerson.ca/datalib/cc01/geospat01.htm
 
This site provides the option to download either Digital Boundary Files (DBF) or 
Digital Cartographic Files (DCF) in Arc/Info or MapInfo formats. In this example, the 
Arc/Info digital cartographic file at the census tract level is used. Often Arc/Info 
Cartographic files(.e00 extension) are found in Arc Export File formats (.exe extension). 
In order to view a desired Arc Export file in ArcMap  9.0, follow the steps below. 
 
*Note – To access the files from a computer located off the Ryerson campus, you must 
be a Ryerson University student (full-time or continuing education), staff or faculty 
member and have a matrix (e-mail) account. 
  
Example: 
 
1. Scroll down to Hamilton (537) and  Download the *.exe file (gct_537b02a_e.exe) for 
Arc/Info to your hard drive (the file size of gct_537b02a_e.exe should be 208KB). 
 
2.  Once this file has been downloaded, browse to it in your directory and use WinZip to 
extract the file. 
 
3a. ) In order to translate the Arc/Info export file for use in ArcMap 9.0, you need to 
open the ArcGIS 8x Tools toolbar located in ArcCatolog. 
 
3b. )  Double-Click on the ArcMap 9.0 icon or Select Start > Programs > ArcGIS > 
ArcMap.  If the Add Data window appears, click Cancel. 

4a.)  Open ArcCatolog by clicking the ArcCatolog button . 
 
4b.)  In the ArcCatolog from the main menu click View > Toolbars > Customize .  
 
4c.)  In the Customize window check off the box next to ArcGIS8x then click close. 
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4d.)  With ArcCatolog still open, click the Conversion Tools  button 
near the top of your screen.  Then click Import from Interchange File. 
 
4e. )  (Figure 1)  In the Import from Interchange File window, browse to the name of 
the recently downloaded .e00 file in the Input File text box.  In the Output Dataset text 
box, browse to the location where you would like to store the new coverage and choose 
an appropriate name.  (in this example we have chosen the name gct_537b02a_e)  
Click OK.  Close ArcCAtalog.   
 

 
(Figure 1) 

 
 
B.  Opening the ArcInfo Coverage in ArcMap 9.0 
 
Note:  If ArcMap is already open, skip to step 2 below. 
 
1.  Double-Click on the ArcMap 9.0 icon or Select Start > Programs > ArcGIS > 
ArcMap. 
2. ArcMap should automatically prompt the option to Add Data. Otherwise, Click the 

Add Data button  .  In the Add data window, browse to gct_537b02a_e.  Click Add. 
The Hamilton CMA should appear, divided into Census Tract boundaries. 
 
C.  Converting From a Coverage to a Shape-file 

1.   Open ArcToolbox by Clicking the small red tool box button in the main menu  
 

2.   In ArcToolbox, Click Conversion Tools > To Shapefile > Feature Class to 
Shapefile (Figure 2). 
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Figure 2 

 
3. In the Feature Class to Shapefile (multiple) window, Select gct_537b02a_e 

from the Input Features drop down menu (Figure 3).  In the Output Folder 
dropdown menu, browse to the location where the file is to be saved.  Click OK.    

 

 
Figure 3 

 
 

4.   Once the execution stage is complete, Click Close.  If a message does not  

appear prompting the addition of the new file to the view, use the Add Data  
button to browse to the selected folder in the previous step and add gct_537b02a_e 
polygon. 
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D. Getting Attribute Census 2001 Data 
 
1.  You may download the data from Census of Canada, 2001: Profile Series located 
at the site listed below: 
 
http://0-www.chass.utoronto.ca.innopac.lib.ryerson.ca/datalib/cc01/profil01.htm 
 
There are 9 subject profiles: 

1. Profile of language characteristics 
2. Profile of aboriginal communities 
3. Age and sex 
4. Marital status, families & household living arrangements, and housing 
5. Language, mobility, and migration 
6. Citizenship, immigration, birthplace, generation status, ethnic origin, visible 

minorities and aboriginal peoples 
7. Labour force activity, class of worker, occupation, industry, place of work, mode 

of transportation, language of work and unpaid work 
8. School attendance, education, field of study, highest level of schooling and 

earnings 
9. Profile of income of individuals, families and households, social and economic 

characteristics of individuals, families and households, housing costs, and 
religion 

 
At the Census tract level there is also an “All Canada file” and a “CMA Toronto Subset” 
As you can see on the website, these files are available at many geographic levels that 
include: 
 
A. Census Subdivision (CSD)   
B. Dissemination Area (DA) 
C. Forward Sortation Area (FSA)   
D. Census Metropolitan Area (CMA) / Census Agglomeration (CA)  
E. Census Tract (CT) 
F. Federal Electoral District (FED) 
 
*Note:  In order to continue this exercise, you must have a version of Beyond 20/20 that 
is version 6.2 or later.  If you do not have this program, you can go to the website below 
and download it: 
 
http://0-www.chass.utoronto.ca.innopac.lib.ryerson.ca/datalib/caq/b2020.htm 
 
-Then select the link beyond-6-2.exe. when prompted to save, select a desired location 
and then save.  The file will be compressed (zipped), thus you have to uncompress it in 
order to use it. 
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1(a).  For this exercise we will use: School attendance, education, field of study, 
highest level of schooling and earnings at the C. Census Tract (CT) Level, 
therefore, select 95f0491xcb01005.  
 
1(b). Then select Open. 
 
A Beyond 20/20 Professional Browser version 6.2, should open.   
 
The first task is to switch the position of the Columns and the Rows.  The Census 
Metropolitan Areas with their census tract numbers should be at the side, while the 
variables should be along the top. 
 

 
(Figure 2) 

 
2.  Select the Geography heading, now hold the button down and drag it over to the 
heading that says Profile of Cens.  Then release the button, now the Census 
Metropolitan Areas with their census tract numbers are in the left column (your 
screen should look like Figure 2). 
 
2(a).  Make sure the Geography heading is highlighted in yellow.  From the Main Menu 
Bar select  Dimension > Search.   

Field = English Desc 
Text to Find = 537 
Type of Selection = Reduce 
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OK 
 
2(b).  We only want Census Tracts which are within the Hamilton Census 
Metropolitan Area, so we will hide the extras.   

Highlight Hamilton (537) 00000 
From the Main Menu Bar select Item > Hide 
Now scroll down to the bottom of the data and highlight the last 3 census 
tracts (0537.01, 0537.02, 0537.03) 
From the Main Menu Bar select Item > Hide 
 

 
 
The ones we have hidden don=t start with 537 with the number in brackets,  
ie 0537.01 (602053701) 00000.  So now if you scroll the table from top to bottom there 
should only be census tracts that in the brackets start with 537. 
 
2(c).  From the Main Menu Bar select File > Save As > Ham01.dbf (Make sure you 
change List Files of Type to dBase File (*.dbf) 
 
2(d).  Select OK and again OK when it says ADuplicate code(s) detected, unique 
codes will be generated@ (You can now close the Beyond 20/20 program as it is not 
needed anymore).  
 
3.  Open Microsoft Excel 
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3(a).  File > Open > (browse to the location of the saved Ham01.dbf) > Open (Make 
sure you change Files of Type to dBase Files (*.dbf) 
3(b).  Select Column A  (Make sure the entire column is highlighted) 

From the Main Menu Bar select Data > Text to Columns 
The Convert Text to Columns Wizard - Step 1 of 3 should open. 
For Original Data Type = Fixed Width 
Click Next 
 
The Convert Text to Columns Wizard Step 2 of 3 should open 
Simply Click Next 
 
The Convert Text to Columns Wizard Step 3 of 3 should open, 
Select the first column (the one with the two decimal places) then 
under the Column Data Format heading Select Text 
Click Finish 
Select OK for the ADo you want to replace the contents of the 
destination  cells?@ 

 
3(c).  Highlight Columns B & C.  Then Edit > Delete > Columns B & C 

(You will also notice that the column title for column A has been altered, simply 
click on the title and change it back to Geography) 

3(e). Highlight the entire worksheet by selecting the grey cell above the Row 1, and 
left of Column A. 

From the Main Menu Bar select Data > Sort  
Sort By = GEOGRAPHY 
Select Ascending 
Click OK 

4.  Save the file.  You may choose to give the file a new name or retain the old one.  
Make sure that you choose DB4 in the Save as type column.  A warning will pop up 
indicating that your dbf file may contain features that are not compatible with DB4 
(dbase IV) and will ask you if you would like to keep the workbook in the current format.  
Click Yes.  Then close Microsoft Excel.  If the save prompt pops up, simply follow the 
procedures above.  Close Microsoft Excel. 
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E.  Opening the Data File in ArcMap 9.0 

1. To open the .dbf file in ArcMap, Click the Add Data  button.  Browse to 
Ham01.dbf.  Click ADD. 
 
F. Joining the Files 
 

1. Right-click the gct_537b02a_e_polygon file in the Layers window.   

 
 

2. In the drop down menu click Joins and Relates > Join.  This will open the Join 
Data window. 

 
3. In the Join Data window 

a. What do you want to join to this layer = Join attributes from a table 
b. Choose the field in this layer that the join will be based on = CTNAME 
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c. Choose the table to join to this layer, or load the table from disk: = Ham01 
d. Choose the field in the table to base the join on:  = GEOGRAPHY 
e. Click OK. 

 
At this point the data from Ham01.dbf should be joined to the gct_537b02a_e_polygon 
table.  To verify this, in the Layers window right click gct_537b02a_e_polygon and 
click Open Attribute Table.  Scroll over to the right.  The new variables should be at 
the right end of the data table.  If the join procedure worked correctly, you have now 
completed the process of getting census data.  In front of you should be a map of the 
Hamilton CMA with 2001 population joined to it. 
 
Currently there are some glitches with the attribute table functions that ESRI has not 
resolved.  These problems result in the attribute table showing error messages or 
coming up completely blank.  If this is the case with the attribute tables after a join has 
been attempted, try one of the following solutions:  exporting the data, re-opening the 
data, and/or adding new fields.  In most cases, exporting the data will solve the 
problem. 
 
Exporting the Data 
When the join procedure is first completed, the joined table exists as a temporary file.  
One solution to this problem is to create a permanent file by Exporting the data. 
 

1. Right-Click gct_537b02a_e_polygon in the Layers window, scroll down and 
click Data, then Click Export Data. 

 
2. In the Export Data window, change the name and the location of the file. Click 

OK.   

3. Use the Add Data button  to add the newly created file.  Right click the 
newly created file and open its Attribute Table. Scroll to the right end of the 
attribute table to view the new variables. If this procedure worked correctly, you 
have now completed the process of getting census data.  In front of you should 
be a map of the Hamilton CMA with 2001 population joined to it. 

 
Re-Opening the Data 
If the entire table is blank, attempt to remove and add gct_537b02a_e_polygon again.    
 

1. Right-click gct_537b02a_e_polygon. Click Remove. 

2. Use the Add Data button  to add gct_537b02a_e_polygon. 
Check the attribute table again.  If this procedure worked correctly, you have now 
completed the process of getting census data.  In front of you should be a map of the 
Hamilton CMA with 2001 population joined to it. 
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Adding New Fields 
A problem exists with the data table fields if the attribute table is blank or if an error 
message exists.  New fields must be created in Ham01.dbf and 
gct_537b02a_e_polygon to correct this problem. 
 

1. Close ArcMap by clicking the ‘x’ in the upper right corner of the screen (do not 
save changes). 

 
2. Open ArcMap Start > Programs > ArcGIS > ArcMap. 

 

3. Use the Add Data button  and browse to Ham01.dbf and 
gct_537b02a_e_polygon.  Add both files.  

 
4. Perform this step for each file: Ham01.dbf and gct_537b02a_e_polygon. 

 
a. Right-click the file name in the Layers window (Ham01.dbf or 

gct_537b02a_e_polygon). 
b. Click Open Attribute table (or click Open for Ham01.dbf). 
c. Click the  button located at the bottom of the Attribute window.   
d. Click Add Field (Figure 5).  

• Ham01.dbf 
1) Set Name = COL2_num 
2) Set Type = Long Integer 
3) Leave everything else alone. 

 
• gct_537b02a_e_polygon 

1) Set Name = COL2_num 
2) Set Type = Long Integer 
3) Leave everything else alone. 
 

e. Click OK.  A field has been created designed to hold values in Long 
Integer format.  Previously, COL2 and CTNAME were strings. 

 
Figure 5 
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5. Assign data to the two new columns (COL2_num and ctname_num).  Open 

ArcToolbox by Clicking the small red toolbox  near the top of the screen.  In 
ArcToolbox, Click Data Management Tools > Fields > Calculate Field to  
open the Calculate Field window (Figure 6). 

 
6. As in Step 4, this procedure must be carried out for both Ham01.dbf and 

gct_537b02a_e_polygon.  
• Ham01.dbf 

a)  Set Input Table = Ham01.dbf 
b) Set Field Name = COL2_num 
c) Set Expression = [COL2] 
d) Click OK. 

• gct_537b02a_e_polygon 
a) Set Input Table = gct_537b02a_e_polygon 
b) Set Field Name =  ctname_num 
c) Set Expression = [CTNAME] 
d) Click OK. 

 

 
Figure 6 

 
7.   Click OK. The new fields are calculated.  To join the newly created files, Click 
Joins and Relates > Join in the drop down menu.  The Join Data window will 
open. 
 
8.   In the Join Data window 
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a) Set What do you want to join to this layer = Join attributes from a table 
b) Set Choose the field in this layer that the join will be based on = ctname_num 
c) Set Choose the table to join to this layer, or load the table from disk = Ham01 
d) Set Choose the field in the table to base the join on = COL2_num 
e) Click OK. 

 
The data from Ham01 should be joined to the gct_537b02a_e_polygon table.  To 
verify the join, Right Click gct_537b02a_e_polygon in the Layers window. Click Open 
Attribute Table.  Scroll to the right end of the attribute table to view the new variables.  
If this procedure worked correctly, you have now completed the process of getting 
census data.  In front of you should be a map of the Hamilton CMA with 2001 population 
joined to it. 
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