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Joining CHASS Data To ArcView Cartographic Files
     
The purpose of this manual is to familiarize the user with data exporting functions in ArcView.
 

Self - extracting ArcView Format digital Cartographic Files for the Census Tract Level are
available from the Data Library : Census 1996 Spatial Data Files, located at the University of
Toronto web address below. 

http://www.chass.utoronto.ca/datalib/cc96/georef96.htm#cma.

At this site you will be given the option to download either digital boundary files (DBF) or digital
cartographic files (DCF) in Arc/Info or MapInfo formats, at the census subdivision, census
tract or enumeration area level. In this example we will use the Arc/Info digital cartographic file
at the census tract level. Often Arc/Info Cartographic files(.e00 extension) are found in Arc Export
File formats (.exe extension). In order to view a desired Arc Export file in ArcView follow the steps
below.

*Note - To use the databases from home, you must be a student (full-time or continuing education), staff or
faculty member of Ryerson with an active Ryerson library card. You must also configure your web browser
to be able to access the databases through the Library's proxy server. Visit
http://www.ryerson.ca/library/info/remote.html for more information.

Example:

1. Scroll down to Toronto (535) and  Download the *.exe file ( Eg. gct_535b.exe) for Arc/Info to
your disk.

2.  Once this file has been downloaded, double-click the *.exe file to extract it.  Quit the DOS
window when it has finished extracting.

You will now use ArcView Import71 program translate data from an Arc/Info export file into an
ArcView readable format.

3.  Double-Click on the Import71 icon or select Start > Programs > ESRI > ArcView GIS 3.2 >
Import71

4 (a).  The Import71 Utility window will open.  

4 (b).  In the Export Filename select Browse locate the *.e00 file in the directory you
downloaded it to, and select it, then select Open. (Eg. C:\esri\tordcf\gct_535b.e00).

4 (c).  In the Output Data Source select Browse and the destination location where you want
the file to be extracted to, then select OK.  After the last back slash (\), type in the output file
name with no extension (Eg. C:\esri\tordcf\gct_535b).  Now select OK.  Another window will

A. Importing An Arc Export File
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appear to tell you that Import Complete then select OK.   

1.  Double-Click on the ArcView GIS 3.2 icon or select Start > Programs > ESRI > ArcView
GIS 3.2 > ArcView GIS 3.2.

2.  In the Welcome to ArcView GIS window select with a new View, then select OK.

3.  In the Add data window, it asks you Would you like to add data to the View now, select
Yes.

4.  In the Add Theme window, change the directory to C:\esri\tordcf\ (for example), then select
on the left side to gct_535b.  Then select OK.

5.  Now maximize the window titled View1, then maximize the window titled ArcView GIS 3.2.

6.  Select the little grey box left the word gct_535b .

What you now have is a layer of all the Toronto CMA by census tracts, in ArcView this layer is
called a theme.

1.  Make sure that Gct_535b is active.  From the Tool Bar select Theme > Convert to
Shapefile and give it a name (Eg. Torctage.shp) (this will be the new file with the combined
boundary file and data file).  Select Yes, when asked to Add shapefile as theme to the view.

2.  Make Gct_535b active, and from the Main Menu select Edit > Delete Themes > Yes To All.  

3.  Now make Torctage active and put a check in the little grey box beside the Torctage.shp
name.   

4. Select the Open Theme Table button (5th button, middle row, left of the binoculars button). 
You should see the combined *.dbf file and boundary file.  Now let’s close this table.

B. Opening The Arc/Info Coverage In ArcView

C. Converting From An Arc/Info Coverage To An ArcView Shapefile

D. Getting Attribute Census 1996 Data
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In order to map data variables the data table must be joined with the .dcf or .dbf file. 

1.  You may download the data from CHASS Canadian 1996 Profile Census Tract Level
located at the site listed below:

http://datacentre.chass.utoronto.ca/census/96_ct.html

2(a). Select the Census Metropolitan Area = Toronto

2(b) Do you want the data categories to be listed as = Columns

2(c) Select the Data Category: Use the Ctrl or Shift keys for multi select.  Always be sure to
select CTName as one of the data categories because this field is used to link to the
spatial data. 

2(d) Select the output format = Text 

2(e) Submit your request = Click Submit Query 
 
A data file should appear on screen. 

3.  In Netscape or Internet Explorer go to  File > Save As > C:\Temp\Tor96.txt (Make sure you
change the extension to .txt NOT .html)

4(a).  Open the .txt file in WordPad 

4(b).  Delete unneeded rows (i.e. header information, empty rows, and the summary data row
(first row of the actual data) until you are left with the raw data and column headings. 

4(c).  File >
Save As >
C:\temp\Tor
96-2.txt
(Text
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Document)

5(a).  Open MICROSOFT EXCEL

5(b).  File > Open > C:\Temp\Tor96-2.txt (Change Files of Type = Text Files)

5(c). The Text Import Wizard Step 1 of 3 should open (see below)
For Original Data Type
Select: FIXED WIDTH
For START IMPORT AT ROW
Select: 1 (or which ever row you want to start importing the data)
For FILE ORIGIN
Select: Windows (ANSI)  - default setting
Click Next

The Text Import Wizard Step
2 of 3 should appear.

At this stage, one can adjust the column breaks.  For this case, since we selected FIXED
WIDTH in Step 1 of 3, the data automatically aligns properly (See figure below).  To
change the columns breaks, if neccessary, just follow the instructions on the screen.
Click on NEXT to proceed.
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The Text Import Wizard Step 3 of 3 should appear.
Since the values are all numeric, we must change the COLUMN DATA FORMAT to
preserve all the decimals points and the 00's after the decimal point.  By default, the data
format is set to GENERAL.  This can be used, however it will eliminate any zeros after the
decimal point.  For example: 15.00 will appear as 15 after the conversion.  Sometimes, we
might need the zeros after the decimal point.  The way to preserve the zeros is to change
the column data format to TEXT.

Click on the first column to highlight the field.  Then, while holding down the Ctrl key, scroll
to the last column and click on it as well while still holding down the Ctrl key.  This will
highlight all the columns.  Once all the columns are selected, under the COLUMN DATA
FORMAT field, select TEXT  (See figure below for a screenshot).

Click on NEXT.

When done, your spreadsheet should look like the following:

5(d).  To save changes, go to 
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File > Save As > C:\Temp\Tor96-3.dbf (dBase Files).  Select Save, then Yes.

Open ArcView Start > ESRI > ArcView GIS 3.2

1. Select the Open Theme Table button (5th button, middle row, left of the binoculars button).
 
2.  Now minimize the View1 window.  And reduce the Attributes of Gct_535b window.

3.  From the Untitled Menu select Tables then select Add.  From the Add Table window select
the *.dbf file (in this example use Tor96-3.dbf) that you want to join.

4 (a).  From the Main Menu select Table > Start Editing (make sure Tor96-3.dbf is active, the
header will be blue if it is active).

4 (b). From the Main Menu select Edit > Add Field.

4 (c).  From the Field Definition window change the Name to ct_name, the Type to  String and
the Width to 7.

4 (d)  The new field ct_name should be highlighted, if it not then click on it. 

4 (e)  From the Main Menu select Field > Calculate.  From Fields double-click on V1; From
Type select String; From Request scroll down to Right and double click on it;  Finally between
the brackets in the equation box put 7.  Select OK.

This will convert 0001.00 (5351012) 00000 into 0001.00

4 (f).  From the Main Menu select Table > Stop Editing > Yes. 

You can join a database table to an ArcView table (e.g., a shapefile theme's attribute table), if
they share a common fields of values. All of the rows selected by the database table's query can
be joined to the ArcView table. 

To join a database table to an ArcView table

1 Open the database table; if the table's window is already open, make it active.
2 Click on the common field's name in the database table to make the field active.
3 Open the ArcView table; if the table's window is already open, make it active.
4 Click on the common field's name in the ArcView table to make the field active.

E. Opening The Data File In ArcView

F. Preparing The Files To Be Joined
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5 Click the Join button .

The contents of the ArcView table changes to include the joined attributes from the database
table while the database table remains open and unchanged. 
The joined attributes are not permanently part of the ArcView table. ArcView gets the joined
attributes from the database using a join query taken from the database table's query at the time
of the join. If the values in the database change you can see those changes by refreshing the
joined table. When you open a saved project, ArcView will recreate the join and retrieve the
appropriate values into the local table.

The join query is not linked to the database table's query. After joining a database table and a
local table, if you change the database table's query in a way that affects which rows are joined,
the rows joined to the local table won't change when you refresh its values. To update which
records are joined, you need to remove the join from the local table then join the tables again
following the steps above.

5 (a).  Make the tor96-3.dbf window active.

5 (b).  Click on the field labelled ct_name.  Now sort datafile records in ascending order (3rd last
button in the middle row).

5 (c). Make the boundary file (Attributes of Gct_535b) window active.  Click on the field
labelled Ctname, to which the datafile will be joined.  Sort boundary file records in ascending
order.

5 (d).  Make sure that the boundary file (Attributes of Gct_535b) is file is active.  From the
Main Menu select Table > Join.  The tor96-3.dbf file should disappear.  Scroll along the
boundary file to see if the *.dbf file data fields are present.

If this was done correctly the new table should look like this:
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1.  Now double-click anywhere on Tor96-3.shp theme, and a Legend Editor window should
appear.

2.  In Legend Type change it from Unique Value to Graduated Colour, by scrolling up.

3.  In the Classification Field change it from None to Total_po.  By default ArcView has broken
down the data into 5 ranges.  Now select Apply.  Then select the X in the top right hand corner
of the Legend Editor window, to close it.

Now we have a theme displaying the Total Population By Census Tract.

4 (a).  If you are not satisfied with the colour schemes or the ranges, then double-click anywhere
on Torctage.shp theme, and a Legend Editor window should appear again.

4 (b).  If you want to change the colour schemes, then at the bottom of the window change the
Color Ramps from Red monochromatic to what ever colour scheme you want, by scrolling
down.  After you have chosen your colour scheme then select Apply.

4 (c).  If you want to change the number of ranges, then from the Legend Editor window, select
Classify > Number of classes change it from 5 to what ever value you want, by scrolling down,
then select OK.

1.  First let’s prepare the legend.  From the Main Menu Bar select Theme > Properties.  A
Theme Properties window should open.  Change the Theme Name from Torctage.shp to
Population, then select OK.  This doesn’t change the name of the file on disk, it just changes it
for the purpose of this View.

2.  Again from the Main Menu Bar select View > Layout >Landscape > OK.

Now in the window titled Layout 1 there are 5 objects: Title, Legend, North Arrow, Scale Bar and
the Theme.

3 (a).  First lets double-click the words View1, then type 1996 Total Population of the Toronto
CMA By Census Tract.  

3 (b).  To change the size of the font, press Ctrl and P at the same time.  Then change the Size
to 36.  Then quit the Font Palette.  Now centre the title between the blue border.    

3 (c).  Now select the theme (map).  To enlarge the theme grab any one of the four black
square dots, and then drag them.  

G. Mapping The Data From The Newly Created Theme

H. Preparing The Layout For Printing
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3 (d).  Once you have made the theme larger, then you must centre it on the layout.  

3 (e).  Once you have centred the theme, then right click any where outside the borders of the
layout, and select Refresh View Frames.  

4.  Next you will double-click on the scale bar.  A Scale Bar Properties windows will open up. 
Change the Units to Kilometers, by scrolling down.  Change the Interval to 50.  Finally, change
the Left Divisions to 0.  Now select OK.  Now centre the scale bar on the bottom of the layout.

5 (a).  Double-click on the North Arrow, a North Arrow Manager window will appear.  You
might want to select a simpler north arrow, like the first one on the second row, now select OK.  

5 (b).  Now move the north arrow to the top right of the layout.  This north arrow appear to be
to large, so we will have to reduce it.  Select the north arrow, now grab one of the four black
square dots and reduce the arrow by bringing the dots closer together.

6.  Now select the legend, and move it down to the bottom right corner of the layout.  

7.  You might want to align the legend and the north arrow.  First select the Legend, now hold
down the shift key on the keyboard, and select the north arrow.  Now press Ctrl and A at the
same time, and select align centre (>|<) at the top.

8.  Now you are ready to print.  File > Print > OK.  

1.  From the Main Menu Bar select Window > View1.

Suppose you want to get rid of some census tracts

2 (a).  From the Main Menu Bar select Theme > Start Editing.  Select the Pointer Tool (Black
Arrow).  Now draw a box that encapsulates the census tracts that you want to remove.  This is
done by selecting an blank area left of the census tracts then dragging the box down and right so
all the census tracts you want removed are in the box.  Now release the button, and select
delete.      

2 (b).  Now we will save our edits.  Theme > Save Edits As.  We will save it to the C:\esri\tordcf
directory as torctage-new.shp.  Theme > Stop Editing > Yes. 

2 (c).  Lets zoom-in to this new theme.  This is easily done by selecting the Zoom To Active
Theme(s) Tool (in the middle row the 10th tool button, look like an arrow pointing down with 2
white pages, with a grey one in between).  

2 (d).  Make sure the torctage-new.shp theme is active.  The active theme is the one that
appear is be raised.  If you select any where on the Population theme, then it is now the active

I. Jazz Up Your Map Or Correct Mistakes
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theme.  Since we are not going to use this theme any more we can delete is by making it active,
and selecting Edit > Delete Themes > Yes. 

2 (e).  So let’s select Theme > Properties.  Change the Theme Name from torctage-new.shp
to Population.  Then select OK.   

3.  From the Main Menu Bar select Window > Layout1.

Now your new theme has been added into your old layout, even the scale bar has changed for
the new theme.  When you last printed you noticed that the blue border you saw on the screen
did not appear on the map.  This is your layout border so you your working area.

4. To add a border select the Neatline Tool ( 3rd last tool on the second row, looks like a white
rectangle.  A Neatline Settings window opened, select Inset from margins.  It’s up to you if
you want to change any of the other Appearance settings.  If not, then select OK.

5.  Now you are going to have to make sure that all 5 object are inside your border (inside black
border).

6.  When it you are trying to move objects around you will notice that they don’t move to the
exact point where you want them.  To change this select Layout > Properties.  Then un-select
Snap to Grid.  Now you can move your object around freely.

7.  Another point, sometimes in the layout when you move an object around it appears that it has
not moved or part of it was left behind, you can either right-click and Refresh View Frames.  Or
you and go to Window > View1 and the back to Window > Layout1, and everything should be
cleaned up.

8.  If you have deleted your north arrow by mistake and want to add another then select the
Frame Tool (last tool on the bottom row).  Hold down the tool while you move down to the north
arrow icon.  You will know the north arrow has been selected because it will be the icon on top. 
Then just create a box in the layout and that’s where your north arrow will appear.          
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Joining Beyond 20/20 Data To ArcView 

1.  Download the self-extracting MapInfo Format Digital Cartographic File for the Census
Tract Level, available from the Data Library: Census 1996 Spatial Data Files webpage.  For
Toronto CMA, this file is gct_535b.exe, located at the address below.  Save this file to
C:\Temp\gct_535b.exe.

http://www.chass.utoronto.ca/datalib/cc96/georef96.htm#cma

2.  Extract the spatial data file by double-clicking the file (gct_535b.exe).  Once the DOS-
Window states Finish - gct_535b on the top, you can close the window.

1.  You may download the data from Census of Canada, 1996: Profile Series located at the
site listed below:

http://www.chass.utoronto.ca/datalib/cc96/profil96.htm

There are nine categories of data available:

Part 1:  age & sex & families data:  population 1991 & 1996, land area, population by sex and
age groups, legal marital status, census families by structure, lone-parent families by sex of
parent, never-married sons and/or   daughters, persons in private households, persons 65 and
over, occupied private dwellings by structure, households by household size.

Part 2:  immigration & citizenship (20% data):  citizenship, place of birth, immigrants by country
of birth, period of immigration, age at immigration. 

Part 3:  mother tongue, home language, & knowledge of official languages (20% data):  mother
tongue,  knowledge of official languages, first official language spoken, home language,
knowledge of non-official    languages.

Part 4:  aboriginal population by type of response (3), and major single response categories. 

Part 5:  ethnic origin by type of response (3). 

Part 6:  labour market activities, occupation and industry, household activities,  place of work and
mode of transportation.

Part 7:  education, mobility and migration. 

A. Getting Geographic Data

B. Getting Attribute Census 1996 Data
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Part 8:  sources of income, family and household income. 

Part 9: families:  social & economic, occupied private dwellings, and housing costs.

These categories are available at six geographic levels:

A. Census Metropolitan Area (CMA) / Census Agglomeration (CA)
B. Census Subdivision (CSD)
C. Census Tract (CT)
D.  Federal Electoral District (FED) (1996 Representation Order)
E.  Enumeration Area (EA) (1987Representation Order)
F.  Forward Sortation Area (FSA)

1(a).  For this exercise we will use Part 7:  education, mobility and migration at the C. Census
Tract (CT) Level, therefore, select PR7CT.IVT. 

1(b). Then select Open It, and then OK.

A Beyond 20/20 Professional Browser, should open.  

The first task is to switch the position of the Columns and the Rows.  The Census Metropolitan
Areas with their census tract numbers should be at the side, while the variables should be
along the top. 

2.  Select the
Geography heading, now hold the button down and drag it over to the heading that says Total
population, 15 to 24 years by school attendance (20% sample).  Then release the button,
now the Census Metropolitan Areas with their census tract numbers are in the left column.

2(a).  Make sure the Geography heading is highlighted in yellow.  From the Main Menu Bar



-14-

select  Dimension > Search.  
Field = English Desc
Text to Find = 535
Type of Selection = Reduce

2(b).  We only want Census Tracts which are within the Toronto Census Metropolitan Area,
so we will hide the extras.  

Highlight the 2 census tracts above the heading Toronto (0279.00 & 0127.00) 
From the Main Menu Bar select Item > Hide
Highlight Toronto (535) 00001
From the Main Menu Bar select Item > Hide
Now scroll down to the bottom of the data and highlight the last 4 census tracts
0005.02, 0330.00, 0001.01 & 0535.00)
From the Main Menu Bar select Item > Hide

The ones we have hidden don’t start with 535 with the number in brackets, ie 0593.00 (5355082)
00001.  So now if you scroll the table from top to bottom there should only be census tracts that
in the brackets start with 535.

2(c).  From the Main Menu Bar select File > Save As > C:\Temp\Data.dbf (Make sure you
change List Files of Type to dBase File (*.dbf)

2(d).  Select OK and again OK when it says “Duplicate code(s) detected, unique codes will
be generated”

3.  Open Microsoft Excel
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3(a).  File > Open > C:\Temp\Data.dbf > Open (Make sure you change Files of Type to dBase
Files (*.dbf)

3(b).  Select Column A  (Make sure the entire column is highlighted)
From the Main Menu Bar select Data > Text to Columns
The Convert Text to Columns Wizard - Step 1 of 3 should open.
For Original Data Type = Fixed Width
Click Next

The Convert Text to Columns Wizard Step 2 of 3 should open
Under the Column Data Format heading Select Text
Click Next

The Convert Text to Columns Wizard Step 3 of 3 should open
Click Finish
Select OK for the “Do you want to replace the contents of the destination 
cells?”

3(c).  Highlight Columns B & C.  Then Edit > Delete > Columns B & C

3(e). Highlight the entire worksheet by selecting the grey cell above the Row 1, and left of
Column A.

From the Main Menu Bar select Data > Sort 
Sort By = GEOGRAP
Select Ascending
Select OK  

3(f).  File > Save As > .dbf file (Data Base File).  Select Save, then Yes.
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1.  Double-Click on the ArcView GIS 3.2 icon or select Start > Programs > ESRI > ArcView
GIS 3.2 

2.  In the Welcome to ArcView GIS window select with a new View, then select OK.

3.  In the Add data window, it asks you Would you like to add data to the View now, select     
 Yes.

4.  In the Add Theme window, select gct_535b.  Then select OK.

5.  Now maximize the window titled View1, then maximize the window titled ArcView GIS 3.2.

6.  Select the little grey box left the word gct_535b .

7.  Click on Theme > Table > a window titled Attributes of gct_535b should open

8 (a).  Currently, the CTName field in the geographic data table is in a different numeric format
than the equivalent field in the census data table.  It therefore must be reformatted to match.  We
will add a new empty field to the table.

(b) From the Main Menu Bar select Table > Start Editing 
Once the editing function has been activated select Edit > Add Field

(c) From the Field Definition window change the Name to ct_name, the Type to  String and the
Width to 7. The new Column ct_name should be there.  We will now populate the empty column
with matching CTName values in numeric format.

(d) The new field ct_name should be highlighted, if it not then click on it. 

(e) From the Main Menu select Field > Calculate.  From Fields double-click on Ctname (or
which ever field contains the ct numbers); From Type select String; From Request scroll down
to Right and double click on it;  Finally between the brackets in the equation box put 7.  Select
OK.

This will convert 0001.00 (5351012) 00000 into 0001.00

C. Editing Geographic File’s Table
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1(a). Make the *.dbf window active.

1(b). Click on the field labelled ct_name. Now sort datafile records in ascending order (3rd las
button in the middle row).

1(c). Make the boundary file (Attributes of Gct_535 b) is active. From the Main Menu select Table
>Join. The tor 96-3.dbf file should disappear. Scroll along the boundary file to see if the *.dbf file
data fields are present. 

D. Preparing The Files To Be Joined


